
10-MINUTE TUTORIAL 

DIGITAL LOGIC CIRCUIT MODELING AND SIMULATION WITH MULTISIM 

Multisim is a schematic capture and simulation program for analog, digital and mixed analog/digital 

circuits, and is one component of the National Instruments “Circuit Design Suite”, which also includes an 

interface to the ELVIS workstation and Ultiboard printed circuit board design tool. 

It is suggested that you begin by taking a few minutes to read the short Multisim tutorial, which is 

presented as Chapter 2 of “Getting Started with NI Circuit Design Suite”, which can be accessed via: 

    Start Menu > All Programs > National Instruments > Circuit Design Suite 11.0 > Documentation > Getting Started 

The basic steps in modeling and analysis of a digital logic circuit are: 

1. Open Multisim and create a “design”. 

2. Draw a schematic diagram of the circuit (components and interconnections). 

3. Design digital test patterns to be applied to the circuit inputs to stimulate the circuit and 

connect signal sources to the circuit inputs to produce these patterns. 

4. Connect the circuit outputs to one or more indicators to display the response of the circuit to 

the test patterns. 

5. Run the simulation and examine the results, copying and pasting Multisim windows into lab 

reports and other documents as needed. 

6. Save the design. 

 

Step 1. Open Multisim and create a design 

Multisim is opened from the Start Menu: 

     Start Menu > All Programs > National Instruments > Circuit Design Suite 11.0 > Multisim 11.0 

      (Version numbers may differ) 

This creates a blank design called “Design1”, as illustrated in Figure 1. Save the file with the desired 

design name via menu bar File>Save As to use the standard Windows Save dialog, shown in Figure 2. 

Navigate to the directory in which you want to save your design, enter the desired file name, and click 

the Save button.  The default file extension for Multisim 11.0 design files is .ms11. 

Note: Create a separate directory on a flash drive or your network drive (H:) to be used 

exclusively for storing your Multisim designs and related files. This will ensure that (1) your files 

will be accessible from any lab computer and (2) your Multisim files will not be mixed in with 

your other files. It is also a good idea to periodically make backup copies of your files as 

protection against loss of data. 

A previously saved design can be opened via File>Open. In the dialog window, navigate to the directory 

in which the design is stored, select the file, and click the Open button. 



 

 

Figure 1. Blank design with default name “Design 1.” 

 

Figure 2. “File > Save As” dialog window. Design to be saved as file ELEC2210_Lab2.ms11. 
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Step 2. Draw a schematic diagram of the circuit 

Place Components 

A schematic diagram comprises one or more circuit components, interconnected by wires. Optionally, 

signal “sources” may be connected to the circuit inputs, and “indicators” to the circuit outputs. Each 

component is selected from the Multisim library and placed on the drawing sheet in the Circuit Window 

(also called the Workspace). The Multisim library is organized into “groups” of related components 

(Transistors, Diodes, Misc Digital, TTL, etc.). Each group comprises one or more “families”, within which 

the components are implemented with a common technology. For designing and simulating digital logic 

circuits in ELEC 2210, two groups are to be used: “Misc Digital” (TIL family only) and “TTL”. 

The “Misc Digital” group has three families of components, of which family “TIL” contains models of 

generic logic gates, flip-flops, and modular functions. These components are technology-independent, 

which means that they have only nominal circuit delays and power dissipation, unrelated to any 

particular technology. Generic components can be used to test the basic functionality of a design, 

whereas realistic timing information requires the use of technology-specific part models, such as those 

in the TTL group.  

To place a component on the drawing sheet, select it via the Component Browser, which is opened via 

the component toolbar or the menu bar. From the menu bar, select Place>Component to open the 

Component Browser window, illustrated in Figure 3.  You can also open this window by clicking on the 

Misc Digital icon in the component toolbar. On the left side of the window, select “Master Database”, 

group “Misc Digital”, and family “TIL”. The component panel in the center lists all components in the 

selected family. Scroll down to and click on the desired gate (NAND2 in Figure 3); its symbol and 

description are displayed on the right side of the window. Then click the OK button. The selected gate 

will be shown on the drawing sheet next to the cursor; move the cursor to position the gate at the 

desired location, and then click to fix the position of the component. The component can later be moved 

to a different location, deleted, rotated, etc. by right clicking on the component and selecting the 

desired action. You may also select these operations via the menu bar Edit menu. 

After a component has been positioned, the component browser is redisplayed and additional 

components can be placed by repeating the above actions.  When the last component has been placed, 

click the Close button to close the component selection window. You may return to the component 

browser at any time to add additional components. 

 



 

Figure 3. Component Browser: Misc Digital TIL family NAND2 gate component selected. 

 

 

Figure 4. A third NAND2 gate is about to be placed on the drawing sheet. 

  



The TIL family part naming convention is as follows. Look at the symbol and function panels on the right 

side of the component selection window to determine the specific function of a selected component. 

1. Basic logic gates:  ANDx, NANDx, NOT, NORx, ORx, XNORx, XORx: where x is the number of gate 

inputs (2-8). 

2. Flip flops: D_FF, JK_FF, SR_FF, T_FF, and latches D_LATCH, SR_LATCH, plus versions that have 

active-high or active-low asynchronous Set and Reset pins (ex. D_FF_POSSR and D_FF_NEGSR, 

respectively).   

3. Standard digital modules: multiplexers, decoders, encoders, counters, ALU, BCD-to-7 segment 

decoder, registers, shift registers, etc. 

4. DIGITAL_PULLUP, DIGITAL_PULLDOWN – to pull a pin to a constant logic 1 and 0, respectively. 

 

Figure 5 shows the schematic diagram with four placed components. Note that each placed gate has a 

“designator” (U2, U3, U4, U5), which can be used when referring to that gate. You can change a 

designator by right clicking on the component, selecting Properties, and entering the desired name on 

the Label tab. 

 

Figure 5. Schematic diagram with all placed components. 



Drawing Wires 

Wires are drawn between component pins to interconnect them. Moving the cursor over a component 

pin changes the pointer to a crosshair, at which time you may click to initiate a wire from that pin. This 

causes a wire to appear, connected to the pin and the cursor. Move the cursor to the corresponding pin 

of the second component (the wire follows the cursor) and click to terminate the wire on that pin. If you 

do not like the path selected for the wire, you may click at a point on the drawing sheet to fix the wire to 

that point and then you can move the cursor to continue the wire from that point. You may also initiate 

or terminate a wire by clicking in the middle of a wire segment, creating a “junction” at that point. This 

is necessary when a wire is to be fanned out to more than one component input. A partially-wired 

circuit, including one junction point, is illustrated in Figure 6. 

 

Figure 6. Partially wired circuit, with one junction point. 

Step 3. Generating test input patterns. 

To drive circuit simulations, Multisim provides several types of “sources” and “instruments” to generate 

and apply patterns of logic values to digital circuit inputs. Sources are placed on the schematic sheet and 

connected to circuit inputs in the same way as circuit components, selecting them from the 

“Digital_Sources” family of the “Sources” group in the component browser. Note that there is a Place 

Source shortcut icon in the tool bar.  



 

There are three basic digital sources: 

1. DIGITAL_CONSTANT – this is a box with a constant logic 1 or 0 output, and would be used where 

the logic value is not to be changed during simulation. To change the output value, right click on 

the box, select Properties, select the desired value on the Value tab, and click the OK button. 

2. INTERACTIVE_DIGITAL_CONSTANT – this is a clickable box that can be connected to a circuit 

input. Clicking on the box toggles its output between 0 and 1. This can be used to interactively 

change a circuit input during simulation. 

3. DIGITAL_CLOCK – this is a box that produces a repeating pulse train (square waveform), 

oscillating between 0 and 1 at a specified frequency. To set the frequency and duty cycle, right 

click on the box, select Properties, select the desired frequency and duty cycle value on the 

Value tab, and click the OK button. 

Figure 7 shows the circuit of Figure 6 with an INTERACTIVE_DIGITAL_CONSTANT connected to each 

input. Note that the initial state of each is logic 0.  Since this circuit has only three inputs, all 8 input 

patterns can be produced (to generate a truth table for the circuit) by manually toggling the inputs. 

 

Figure 7. INTERACTIVE_DIGITAL_CONSTANT sources connected to circuit inputs. 

  



Another mechanism to apply all possible input combinations to a circuit is to connect a DIGITAL_CLOCK 

to each input, with the frequency of the first clock set to some value N, the second to 2N, the third to 

4N, etc.  This produces the pattern shown in Figure 8. Looking at these waveforms, it can be seen that 

the initial pattern is 000, changing to 001, 010, etc. Of course, DIGITAL_CLOCK sources would also be 

used to drive the clock inputs of sequential circuits. 

 

 

 

 

 

Figure 8. Three clocks used to produce a sequence of 8 digital patterns 

 

Multisim also provides a number of simulated “instruments,” comparable to bench-top electrical test 

instruments, that can be incorporated into electrical simulations. Two of these, in particular, can be 

used to stimulate the inputs of a digital logic circuit: the NI ELVISmx “Digital Writer” and the “Word 

Generator”.  The designation “NI ELVISmx” indicates a simulated version of a physical instrument on the 

ELVIS workstation. Recall that the Digital Writer and Digital Reader, illustrated in Figure 9, were used in 

the first lab session to provide inputs to, and display outputs of digital logic circuits. On the ELVIS 

workstation, these instruments are connected to a circuit via the Digital I/O connections at the right side 

of the unit. Recall that each Digital Reader/Writer can be connected to up to eight signals. 

 

Figure 9. NI ELVISmx Digital Writer and Digital Reader Instruments 

In Multisim, the Digital Writer instrument can be selected via the shortcut icon on the right side of the 

main window (click on the button “NI ELVISmx Instruments” and select the NI ELVISmx Digital Writer.) 

You may also select this instrument from the menu bar Simulate>Instruments>NI ELVISmx 

Instruments>NI ELVISmx Digital Writer. The selected instrument is placed on the drawing sheet and 

connected to wires in the same way as any other component, as shown in Figure 9. 
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To use the Digital Writer, open the instrument by double-clicking on its symbol in the schematic, 

opening the Digital Writer window shown in Figure 10. The default is for a pattern to be applied 

manually, while a simulation is running. Clicking on the switches in the window toggles them between 0 

and 1, with the values applied to the eight outputs having the same numbers as the switches. For the 

example circuit in Figure 10, only three of the outputs are connected to the circuit, allowing the user to 

easily produce the eight possible 3-bit patterns. If desired, one can also produce automatically-

generated sequences of inputs (binary counts, etc.) by changing the selection in the “Pattern” box of the 

window. 

 

Figure 10. Pattern 101 applied by Digital Writer; Digital Reader shows 1 on output. 

One additional mechanism for generating digital patterns is the “Word Generator” instrument, which 

can be added to the circuit via the shortcut icon on the right side of the main window, or via the menu 

bar Simulate>Instruments>Word Generator. Figure 11 shows a Word Generator (XWG1) connected to 

the three circuit inputs.  The Word Generator produces a sequence of patterns, each containing from 1 

to 32 bits.  

To specify the patterns and the rate at which they should be produced, double click on the Word 

Generator symbol, producing the window shown in Figure 12. The Control buttons on the left of this 

window allow patterns (1) to be continuously applied and repeated (Cycle button), (2) a single set of 

patterns to be applied (Burst button), or (3) a single pattern to be applied (Step button). The patterns 



displayed in this window will be applied in the order listed, and can be entered manually or generated 

automatically.  For automatically-generated patterns, press the Set button, producing the Settings 

window of Figure 13. In this example, “Up Counter” is selected to produce a sequence of binary 

numbers, “Buffer Size” is set to 8 to limit the sequence to 8 numbers, and “Initial pattern” is set to 0. 

Note that the 8 binary numbers are displayed in the Word Generator window of Figure 12. The rate at 

which the patterns are to be applied to the circuit is specified via the Frequency box of the Word 

Generator window. In Figure 12, the frequency has been set to 1KHz, which means that 1000 patterns 

will be generated each second, or one pattern every 1msec. 

 

Figure 11. Word Generator connected to the circuit inputs 

 

Figure 12. Word Generator window showing count up pattern 



 

Figure 13. Word Generator Settings window 

Step 4. Connect circuit outputs to indicators 

To facilitate studying the digital circuit output(s), Multisim provides a variety of “indicators”. For digital 

simulation, the most useful are digital “probes”, hex displays, and the Logic Analyzer instrument.  A 

probe, illustrated in Figure 13, displays a single digital value as ON or OFF (the probe is “illuminated” in 

Figure 14, indicating an ON condition). The PROBE family of the Indicators group includes a generic 

PROBE_DIG and several PROBE_DIG_color indicators (color = BLUE, GREEN, ORANGE, RED, YELLOW). 

The probe in Figure 14 is PROBE_DIG_BLUE.  This circuit can be verified by manually changing the three 

INTERACTIVE_DIGITAL_CONSTANT inputs to each of the 8 possible combinations, and recording the 

probe value for each combination to create a truth table. 

 

Figure 14. DIGITAL_PROBE_BLUE connected to circuit output. 



 
The HEX_DISPLAY family contains a variety of displays that show multi-bit values as hexadecimal 

numbers. This would be useful for such circuits as binary counters, as illustrated in Figure 15. In this 

example, the DCD_HEX_GREEN indicator is a “decoded” hex display digit, which means that the 

indicator displays the hex number corresponding to the states of its four inputs. 

 

Figure 15. DCD_HEX_GREEN decoded hex indicator displays a counter output. 

Another useful indicator is the NI ELVISmx Digital Reader instrument, described earlier and shown in 

Figures 9 and 10. The Digital Reader is essentially just a set of 8 lights that show the states of the wires 

connected to its inputs. Logic 1 turns the light ON and logic 0 turns it off. (The circuit output in Figure 10 

is currently 1.) As mentioned above, the Digital Reader corresponds to the physical instrument available 

on the ELVIS workstation. 

For studying sequences of logic states over time, one can use the Logic Analyzer instrument, shown in 

Figures 11 and 15. A logic analyzer is an instrument that captures and displays sequences of digital 

values over time, with the sequences displayed as waveforms rather than as tables of numbers. The 

Multisim Logic Analyzer instrument can capture and display up to 16 signals. Samples are triggered 

either by an internal clock (N samples per second) or by an external clock.  Figure 16 shows the Logic 

Analyzer display of the three inputs and the output of the circuit in Figure 11. It shows the response of 

the circuit to the burst of Word Generator values shown in Figure 12, plus the internal clock that was 

used to capture samples. 

The logic analyzer must be configured to capture values at the correct sampling times. This is done by 

clicking on the Set button in the Clock area under the logic analyzer display, opening the Clock Setup 

window shown in Figure 17. Since the word generator was configured to generate patterns at a rate of 

1KHz, a clock rate of 2KHz was set for the logic analyzer to make it capture two values for each input 

pattern.   



 

 

Figure 16. Logic Analyzer display of the 3 circuit inputs and circuit output of Figure 11, for the 8 

patterns produced by the Word Generator shown in Figure 12. 

 

Figure 17. Logic analyzer sampling clock setup. 

 

  



Step 5. Run the simulation 

A simulation is initiated by pressing the Run (green arrow) button in the toolbar or via the menu bar via 

Simulate>Run.  Alternatively, simulation can be initiated from a Word Generator by pressing the Cycle, 

Burst, or Step buttons.  

You may capture any window and paste it into a Word or other document for generating reports. An 

individual window is captured by pressing the ALT and Print Screen keys concurrently. You may then 

“paste” the captured window into a document via the editing features of that document.  To capture a 

circuit diagram in the main window, the simplest method is via the menu bar Tools>Capture Screen 

Area. This produces a rectangle whose corners can be stretched to include the screen area to be 

captured; the “copy” icon on the top left corner is pressed to copy the area, which may then be pasted 

into a document. The circuit images in Figures 8, 10 and 14 were copied in this manner. 

Step 6. Save the design and close Multisim 

The simplest way to save a design is to click the Save icon in the Design Toolbar on the left side of the 

window, directly above the design name.  Alternatively, you may use the standard menu bar File>Save. 

As mentioned earlier, you should save all designs in a special course directory on either your network 

(H:) drive or on a flash memory device.  

Multisim is exited as any other Windows program. 

 


